Partial degradation on Arduino Cloud and IoT connectivity

Incident Report for Arduino

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:48 UTC

Update

Device connectivity, data ingestion, IoT Cloud UI, and Dashboard are fully operational.
However, issues persist with sketch compilation through the Cloud Editor and with OTA updates.
Our team is actively working to resolve these.
Posted Oct 20, 2025 - 14:21 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:18 UTC

Monitoring

We are impacted by an incident related to AWS infrastructure. The issue started at 7:11 AM UTC.
Users might experience partial outage or delays in data loading and board connectivity to the cloud.
See more: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:57 UTC
This incident affected: Arduino Cloud (Editor, IoT Cloud UI and Dashboards, Device connectivity, API Requests, Historical data ingestion).